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Abstract

These notes describe how to setup Eclipse to develop an OSATE2 plug-in to support an
AADL annex sub-language with XTEXT.
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1 Assumptions and conventions

These notes assume that the reader is familiar with JAVA, ECLIPSE, AADL, OSATE2, XTEXT and
EMF /ECORE. It is recommended that the reader follows some ECLIPSE plug-in development tuto-
rial, as well as the basic XTEXT tutorials found on http://www.eclipse.org/Xtext/documentation.html.
For the AADL standard, see [1].

1.1 Conventions
1.1.1 Paths

In most of these notes we will use the Unix-style notation for paths, e.g., /home/user/somefolder,
which is common to Linux and MacOSX. Converting this path to Windows-like notation is usually
straight-forward: replace every forward slash ‘/’ with a backslash ‘\’ and prepend the drive letter
followed by a colon. So the path /one/two/three becomes the path C:\one\two\three.

In these notes we will use the path /home/user/osate-dev for the home path where we will
install the OSATE2 development environment, the user workspace, the GIT repositories, and the
OsATE2 runtime workspace. However the reader can any suitable paths instead of these.

1.1.2 Code samples and meta-variables

We will use fixed size courier font for code samples and paths, and italic courier font
for meta-variables that should be replaced by concrete names or other strings specific to the user’s
project. In larger pieces of code we use the prefix “sample” as a generic name prefix for different
entities such as class names or method names, to be substituted by the user’s specific names.


http://www.eclipse.org/Xtext/documentation.html

2 Installation

Install Osate2 from sources. You can follow the instructions from the OSATE2 wiki website:
https://wiki.sei.cmu.edu/aadl/index.php/Getting_Osate_2_sources but you might run into
problems with XTEXT if you obtain it from the source provided there, hence the following is rec-
ommended instead:

1. Install ECLIPSE MODELING T'ooLs (MDT) version 4.3 (KEPLER) or later. It can be obtained
at https://wuw.eclipse.org/downloads/:

(a) Download the apropriate archive (eclipse-modeling-kepler-SR2-platform.zip or
eclipse-modeling-kepler-SR2-platform.tar.gz) where platform is the platform
where you are going to install Eclipse, for example, for the standard 64 bit linux distri-
bution platform is linux-gtx-x86_64, for the standard MacOSX 64 bit distribution,
it is macosx-cocoa-x86_64, and for the standard Windows distribution it is win64, etc.

(b) Extract this archive' in some folder, e.g., /home/user/osate-dev. Once extracted it
should have created a folder called “eclipse” (/home/user/osate-dev/eclipse) with
an executable called “eclipse” inside it.?

(¢) Run the EcCLIPSE executable. It will ask you for a workspace folder. For example,
/home/user/osate-dev/workspace.

2. Install XTEXT:

(a) Click on “HelprEclipe Marketplace...”
(b) In the “Find” search box type “Xtext” and hit “Enter” or click on “Go”.

(c) The first entry should show the latest version of XTEXT (2.6.0 at the time of this writing).
Click on “Install”.

(d) When it asks you to confirm the selected features, make sure that “Xtext” and “Xtext
SDK” are ticked. Click on “Confirm>”

(e) Select “I accept the terms of the licence agreement” and click “Finish”.

(f) Tt will pop up a security warning window, saying that you are installing software that
contains unsigned content. Click on “OK”.

(g) It will pop up a window asking if you would like to restart now. Click on “Yes”.
3. Install GOOGLE GUICE:

a) Click on “Help> Install New Software...”

(a)
(b) Click the “Add...” button.
()

)

(d) In the Location field enter:

In the Name field enter “Google Guice”.

http://guice-plugin.googlecode.com/svn/trunk/eclipse-update-site/

LIf you are on MacOSX, avoid using the built-in unarchiver facility because due to a bug, it will corrupt the
executable when extracting it. You will have to use a third-party archive extractor instead.
2Called “eclipse.exe” under Windows.


https://wiki.sei.cmu.edu/aadl/index.php/Getting_Osate_2_sources
https://www.eclipse.org/downloads/
http://guice-plugin.googlecode.com/svn/trunk/eclipse-update-site/

Click “OK”.
Under the table an entry “Guice” should appear with a checkbox. Tick the checkbox to
select it.

Click “Next” and “Next” again.
Select “l accept the terms of the licence agreement” and click “Finish”.

It will pop up a security warning window, saying that you are installing software that
contains unsigned content. Click on “OK”.

It will pop up a window asking if you would like to restart now. Click on “Yes”.

4. Install the Graphical Editing Framework Zest Visualization Toolkit (GEF-ZVT):

Click on “Help > Install New Software...”
Click the “Add...” button.

In the Name field enter “GEF”.

In the Location field enter

http://download.eclipse.org/tools/gef/updates/releases/

Click “OK”.

Under the table an entry “GEF (Graphical Editing Framework)” should appear with a
checkbox and a right-pointing arrow. Click on the right-pointing arrow to unfold a list
of sub-components.

Select (tick) the box for “Graphical Editing Framework Zest Visualization Toolkit”.
Click “Next” and “Next” again.
Select “I accept the terms of the licence agreement” and click “Finish”.

It will pop up a window asking if you would like to restart now. Click on “Yes”.

5. Install SLF47J:

Click on “Help®> Install New Software...”
In the “Work with:” field, click the down-pointing arrow to unfold the list of update sites.
Choose “Kepler - http://download.eclipse.org/releases/kepler”.

Look for “slf4j” either by typing it in the text-box field below the “Work with:” field, or
by unfolding “General Purpose Tools”. The feature’s full name is “m2e - slf4j over logback
logging (Optional)”. Select (tick) it.

Click “Next” and “Next” again.
Select, “I accept the terms of the licence agreement” and click “Finish”.

It will pop up a window asking if you would like to restart now. Click on “Yes”.

6. Install the core OSATE2 plug-in sources:

(a)

Once you restart ECLIPSE, if there is a “Welcome” tab in the ECLIPSE environment, close
it.


http://download.eclipse.org/tools/gef/updates/releases/

(b) Select “Filer>Import...”

(¢) Unfold the option “Git”

(d) Select “Projects from Git” and click “Next”.
(e) Select “Clone URI” and click “Next”.

(f)

f) Under “Location”, in the “URI” field, enter
“https://github.com/osate/osate2-core.git” and click “Next”.

(g) Make sure that the baranch “master” is selected® and click “Next”.

(h) Under “Destination”, in the “Directory:” field enter a directory where you want to down-
load and store your local copy of the OSATE2 source repositories. For example,

/home/user/osate-dev/git/osate2-core

(i) Click “Next”.*
(j) When asked for the wizard for project import, choose “Import existing projects” and click
“Next”.

(k) In the following dialog box all projects should be selected. Click “Finish”. In the “Package
Explorer” view of your ECLIPSE workspace all core OSATE2 plugins should appear.

(1) IMPORTANT: under the plugin org.osate.aadl2 there should be a file called
“aadl2-nouml.genmodel”

This file should be inside the “model” folder. This file is essential to be able to cre-
ate XTEXT languages that have access to AADL meta-model elements. Unfortunately,
in the latest version of OSATE2 at the time of this writing (June 14, 2014), this file
was removed. You will have to ask the OSATE2 developers to either put the file back,
or provide you with an alternative. However, since at the time of this writing there
is no alternative, the rest of these notes assume that you have a copy of this file
and when you create a plugin called sampleplugin you create a “prerequisites” folder
“prereqs” inside the plugin, and a “models” folder inside prereqs, where you should
store a copy of aad12-nouml.genmodel, as well as copies of the files “aad12.ecore” and
“aadl2.genmodel” found under org.osate.aadl2/model. Summarizing, you should
have in your plugin, the following files:

i. sampleplugin/prereqs/models/aadl2.ecore
ii. sampleplugin/prereqs/models/aadl2.genmodel

iii. sampleplugin/prereqs/models/aadl2-nouml.genmodel
7. Setup a Run configuration:

(a) On the ECLIPSE menu select “Run>Run Configurations...”.
(b) Select “Eclipse Application”.
(c) Right-click on it and select “New”.

3These procedure has been tested only with the master branch. If you want to reproduce this procedure, uncheck
the annex and develop branches.
4Usually the download gets slow at around 92%, but it will eventually end.



In the field “Name:” enter “Osate2”

In the field “Location:” choose a location for the runtime OSATE2 workspace. For example
/home/user/osate-dev/runtime-osate-workspace.

In the field “Run a product:” click the down-pointing arrow to unfold and select the
option “org.osate.branding.osate2”.

Click on the “Arguments” tab.

Under “VM Arguments” add “-XX:MaxPermSize=256m -Xmx1200m”

Click “Apply”.

Click “Run”. OSATE2 starts, and when you close it, the run configuration will appear

under the list or Run Configurations as well as the list that appears when you click on
the down-pointing arrow next to the “Run” button on the ECLIPSE toolbar.



3 Outline

Here we give an overview of the whole process of creating the plugin(s). The following sections
ellaborate on the details.

1. Create the syntax and UI plugins: (Section 4)

Create an XTEXT project.
Write an initial XTEXT grammar.
Configure the main XTEXT project (workflow and dependencies)

Generate XTEXT artifacts (produces three or four additional plugin projects, incuding
the “UI” project).

(e) Configure the XTEXT Ul project (setup extensions, create custom activator class)

(f) Add parser class for your annex and corresponding extension.
2. Create the analysis plugins: (Section 5)

a) Create a Java plug-in project

(
(

)
b) Configure the project (dependencies, actions, extensions, etc.)
(c) Create actions.
(d)
)

d

(e) Set up a run configuration.

Create visitors.



4 The core XTEXT project

4.1 Creation

1. Create a new XTEXT project:

(b)

(c)
(d)

Go to “Filer New> Project...”

Unfold “Xtext” and choose “Xtext Project” (don’t choose “Xtext Project from Existing Ecore
models”®) and click “Next”.

Enter a project name. While any name should work, it is suggested to use a name within
the OSATE2 namespace, for example org.osate.xtext.aadl2.sampleannex.

Enter a name for your annex language. Again, it is suggested to use a name within the
OSATE2 namespace, for example org.osate.xtext.aadl2.sampleannex.SampleLang.

Enter a file extension for your annex language. For example samplang.
Click “Finish”.

will create four plug-in projects:

org.osate.xtext.aadl2.sampleannex: the core XTEXT project which contains the
grammar and once compiled, will contain the main syntax artifacts, namely the ECORE meta-
model (abstract syntax classes) for your language, the runtime features and other sup-
porting infrastructure such as a serializer, validator, formatter, as well as skeletons for
generators, etc.

org.osate.xtext.aadl2.sampleannex.ui: the user-interface plugin which provides a
link between your language and the ECLIPSE/OSATE2 user-interface.

org.osate.xtext.aadl2.sampleannex.tests: the plugin for unit-tests.

org.osate.xtext.aadl2.sampleannex.sdk: the SDK plugin for creating update-sites.

Each of the plugins contains three source folders:

src: where where hand-written source XTEXT, XTEND and JAVA packages and class files
are placed.

src-gen: where JAVA packages and class files generated from XTEXT are placed.

xtend-gen: where JAVA packages and class files generated from XTEND are placed.

Initially only the core project (org.osate.xtext.aadl2.sampleannex) cointains something,
namely the files:

(a)
(b)

src/org.osate.xtext.aadl2.sampleannex/SampleLang.xtext: the source file for your
XTEXT grammar, and

src/org.osate.xtext.aadl2.sampleannex/GenerateSampleLang.mwe2: the workflow
(written in the MWE2 workflow language) that generates all runtime artifacts and infras-
tructure from your grammar. This is the file that you run to generate the infrastructure
and where most configuration is done.

5Creating the X TEXT project from an existing EcorRE meta-model seems to be incompatible with the AADL meta-

model, so it

is not recommended.



4.2

Edit the XTEXT source file (src/org.osate.xtext.aadl2.sampleannex/SampleLang.xtext)
and enter something like the sample shown in Figure 1 on page 11. Pay attention to the places
where the annex name and language name are used. You will likely need to inherit from some
classes from the AADL metamodel. To do that, it is necessary to import the AADL ecore meta-
model (line 5), and then you refer to the AADL classes by using the prefix “aad12::”. You will
need to define at least, a subclass for “aad12: : AnnexLibrary” and “aadl2: : AnnexSubclause”
as shown in lines 10 and 13 respectively.

. Look in the folder model folder of the org.osate.aadl plugin project. If there is a file called

aadl2-nouml.genmodel, then skip the following step.

. In the main project org.osate.xtext.aadl2.sampleannexcreate a folder called prereqs/models

and copy into it the files:

(a) aadl2.ecore: found in the folder model folder of the org.osate.aadl plugin project.
(b) aadl2.genmodel: found in the folder model folder of the org.osate.aadl plugin project.

(c) aadl2-nouml.genmodel: it was previously found in the model folder of the org.osate.aadl
plugin project but was removed from the master branch of the sources. At this point
there is no alternative solution but to ask the OSATE2 developers to provide this file.

Workflow configuration

. Open the workflow file src/org.osate.xtext.aadl2. sampleannex/GenerateSamplelLang.mwe2

and under the StandaloneSetup section, comment out or remove the following lines:

registerGeneratedEPackage = "org.eclipse.xtext.xbase.XbasePackage"
registerGenModelFile = "platform:/resource/org.eclipse.xtext.xbase/

model/Xbase.genmodel"

Then, if the file aad12-nouml . genmodel is in the model folder of the org.osate.aadl2 plugin
project, then add in their place the following line:5

registerGenModelFile = "platform:/resource/org.osate.aadl2/

model/aadl2-nouml .genmodel’’

But if it is not, and you had to do step 4 in the previous section, then use the following line
instead:

registerGenModelFile = "platform:/resource/org.osate.xtext.aadl2.sampleannex/

prereqs/models/aadl2-nouml.genmodel’’

. (Optional) if (and only if) you created the XTEXT project from an ECORE model, then under

“language”, add or uncomment the following line (after the GrammarAccess fragment):

fragment = ecore.EcoreGeneratorFragment auto-inject {}

SWrite it in one line.

10



(S

grammar org.osate.xtext.aadl2.sampleannex.Samplelang
with org.eclipse.xtext.common.Terminals

3 generate Samplelang "http://www.osate.org/xtext/aadl2/sampleannex/SampleLang"

o

© 0 N o

10
11
12

13
14

15 4

16
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18
19
20

2
22
23
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-

25

26
27

28

29

31

import "http://www.eclipse.org/emf/2002/Ecore" as ecore
import "platform:/resource/org.osate.aadl2/model/aadl2.ecore" as aadl2

SamplelLangGrammarRoot
"library’ 1lib = SamplelLangAnnexLibrary
| "subclause’ subclause = SamplelangAnnexSubclause

’

AnnexLibrary returns aadl2::AnnexLibrary:
SampleLangAnnexLibrary

’

AnnexSubclause returns aadl2::AnnexSubclause:
SampleLangAnnexSubclause

7

SamplelLangAnnexLibrary returns SamplelangAnnexLibrary:
{SampleLangAnnexLibrary}

things += Thing+
7
SampleLangAnnexSubclause returns SampleLangAnnexSubclause:

{SampleLangAnnexSubclause}

goods += Stuff+
’
Thing:

"thing’ name=ID ’ ;'
r

Stuff:
"stuff’ name=ID ’;’

Figure 1: A sample XTEXT grammar.

11



And comment or remove the line

fragment = ecore2xtext.Ecore2XtextValueConverterServiceFragment auto-inject {}

4.3 Plug-ins configuration

1. Set the plug-in dependencies:

(a) In project org.osate.xtext.aadl2.sampleannex:

i. Open (double-click) on the file META-INF/MANIFEST.MF.
ii. Open the “Dependencies”’ tab.
iii. Click on “Add...” and enter “org.osate.aadl2”
iv. Click on “Add...” and enter “org.osate.core”
v. Save all (“File>Save All” or Shift+Ctrl+S)

(b) In project org.osate.xtext.aadl2.sampleannex.ui

i. Open (double-click) on the file META-INF/MANIFEST. MF.
ii. Open the “Dependencies”’ tab.
iii. Click on “Add...” and enter “org.osate.aad|2”
iv. Click on “Add...” and enter “org.osate.aadl2. modelsupport”
v. Click on “Add...” and enter “org.osate.annexsupport”
vi. Save all (“File>Save All” or Shift+Ctrl+S)

2. Run the workflow:

(a) Select the file stc/org.osate.xtext.aadl2.sampleannex/GenerateSampleLang . mwe2
(b) Right click and select “Run As>MWE2 Workflow”

If you don’t get any exception messages on the console and you see the message “Done”, then the
generation was succesful. If you had any trouble reported, go back to the previous steps and make
sure that you have followed the steps precisely.

4.4 Setup the activator
You need to create an activator class for the UI plugin.

1. Create subclass of
org.osate.xtext.aadl2.sampleannex.ui.internal.SampleLangActivator
and save it in src/org.osate.xtext.aadl2.sampleannex.ui. Call it, for example,

org.osate.xtext.aadl2.sampleannex.ui.SampleLangCustomActivator

12



-

package org.osate.xtext.aadl2.sampleannex.ui;

2 import org.osate.xtext.aadl2.sampleannex.ui.internal.SamplelLangActivator;

import org.apache.log4j.Logger;

import org.osgi.framework.BundleContext;

3
4 import org.osate.core.OsateCorePlugin;
5
6

import com.google.inject.Injector;

7 public class SampleLangCustomActivator extends SamplelLangActivator {

8

9
10
11
12
13
14
15
16
17
18
19
20
21

22
23
24
25

26 }

@Override
public void start (BundleContext context) throws Exception {
super.start (context) ;
try {
registerInjectorFor (ORG_OSATE_XTEXT_AADL2_SAMPLEANNEX_SAMPLELANG) ;
} catch (Exception e) {
Logger.getLogger (getClass()) .error (e.getMessage (), e);
throw e;
}
}
@Override
public Injector getInjector (String languageName) {
return OsateCorePlugin.getDefault () .getInjector (languageName) ;

}

protected void registerInjectorFor (String language) throws Exception {
OsateCorePlugin.getDefault ()
.registerInjectorFor (language, createlnjector (language));

Figure 2: Activator for the UI plugin:
src/org.osate.xtext.aadl2.sampleannex.ui/SampleLangCustomActivator. java.

This class should create and register an injector for the language, which is done with the
“createInjector” method inherited from the parent SampleLangActivator, and the method
“registerInjectorFor” from the instance of the default OSATE2 plugin. An example is found
in Figure 2 on page 13. Pay attention to use the right annex and language names in the package
and class names as well as in the constant used when invoking “registerInjectorFor” in
line 12.

2. Register the activator:

(a) Open (double-click) the file META-INF/MANIFEST.MF of the project
org.osate.xtext.aadl2.sampleannex.ui

(b) Go to the “Overview” tab.
(c) Click “Browse...” in the “Activator” field and locate the file

org.osate.xtext.aadl2.sampleannex.ui.SampleLangCustomActivator

13



created in the previous step. (When you type the name of the class it should appear in
the list of options.)

(d) Save all (“FilerSave All” or Shift+Ctrl+S)

4.5 Setup the parser

Here we create the class that links the OSATE2 parser to the annex parser generated by XTEXT for
your annex language.

1. Create a package org.osate.xtext.aadl2.sampleannex.parsing inside the project
org.osate.xtext.aadl2.sampleannex.ui.

2. Inside this package create a class that implements AnnexParser as shown in Figure 3 on page
15. Make sure that you replace the appropriate names for sampleannex and SampleLang, and
in particular in the calls “getGrammarAccess() .getSampleLangAnnexLibraryRule()” (line
36) and “getGrammarAccess() .getSampleLangAnnexSubclauseRule()” (line 47).

3. Create an extension to the org.osate.annexsupport.parser extension point:

(a) Open (double-click) the file META-INF/MANIFEST.MF of the project

org.osate.xtext.aadl2.sampleannex.ui

(b) Go to the “Extensions” tab.

(c¢) Click on “Add...” and enter “org.osate.annexsupport.parser”’ and click “Finish”.

(d) Select the new org.osate.annexsupport.parser extension and enter in its fields:

i.
ii.
iii.
iv.

V.

field “id”: org.osate.xtext.aadl2.sampleannex.ui.parser

field “name”: SampleLang Annex Parser

field “class™ org.osate.xtext.aadl2.sampleannex.parsing.SampleLangAnnexParser
field “annexName”: SamplelLang

field “annexNSURI”: http://www.osate.org/xtext/aadl2/sampleannex/SampleLang

(e) Save all (“File>Save All” or Shift+Ctrl+S)

You can test the syntax now, by running OsATE2(click the down-pointing arrow next to the “Run”
button on the toolbar and select “Osate2”). If you get a conflict with other plugins, just select and
close any conflicting plugin.

You can try a test such as the one in Figure 4 on page 16. If the keywords you used in your
grammar appear highlighted, the parser is working.

14
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package org.osate.xtext.aadl2.sampleannex.parsing;

import
import
import
import
import
import
import
import
import
import

public

org.osate.aadl2.AnnexLibrary;

org.osate.aadl2.AnnexSubclause;
org.osate.aadl2.modelsupport.errorreporting.ParseErrorReporter;
org.osate.annexsupport.AnnexParseUtil;
org.osate.annexsupport.AnnexParser;

org.osate.core.OsateCorePlugin;
org.osate.xtext.aadl2.sampleannex.parser.antlr.SampleLangParser;
org.osate.xtext.aadl2.sampleannex.services.SampleLangGrammarAccess;
com.google.inject.Injector;

antlr.RecognitionException;

class SamplelLangAnnexParser implements AnnexParser {

private Injector injector = OsateCorePlugin.getDefault ()

.getInjector ("org.osate.xtext.aadl2.sampleannex.SampleLang") ;

private SamplelangParser theSamplelLangParser ;

protected SamplelangParser getParser() {

}

if (theSamplelangParser == null) ({
if (injector == null) {
injector = OsateCorePlugin.getDefault ()
.getInjector ("org.osate.xtext.aadl2.sampleannex.SampleLang");
}
theSamplelLangParser = injector.getInstance (SamplelLangParser.class);

}

return theSamplelangParser;

protected SamplelLangGrammarAccess getGrammarAccess () {

}

return getParser () .getGrammarAccess();

@Override
public AnnexLibrary parseAnnexLibrary (String annexName, String source,

}

String filename, int line, int column,
ParseErrorReporter errReporter) throws RecognitionException {
AnnexLibrary annex_lib_ast_root =
(AnnexLibrary) AnnexParseUtil.parse (getParser(),
source,
getGrammarAccess () .getSamplelLangAnnexLibraryRule (),
filename, line, column, errReporter);
return annex_lib_ast_root;

@Override
public AnnexSubclause parseAnnexSubclause (String annexName, String source,

String filename, int line, int column,
ParseErrorReporter errReporter) throws RecognitionException {
AnnexSubclause annex_clause_ast_root =
(AnnexSubclause) AnnexParseUtil.parse (getParser(),
source,
getGrammarAccess () .getSampleLangAnnexSubclauseRule (),
filename, line, column, errReporter);
return annex_clause_ast_root;

Figure 3: Thél%nnex parser.
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package testl
public

annex Samplelang {*x
thing hello ;
thing goodbye;
*x};

thread T

8 annex SamplelLang {*#*

©

10
11
12

13

stuff one;
stuff two;
*x};
end T;

end testl;

Figure 4: An annex test.
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5 An analysis plug-in

An analyzer for your annex language should be in its own separate plugin. Here we show how to

do a simple analyzer with one action. This adds one new menu entry and one button to execute on

a model.

5.1 Create a new plugin

Make a new plug-in as a Java plug-in project called, for example:
org.osate.xtext.aadl2.sampleannex.analysis

7

1. Go to “File> New > Project...” and select “Plug-in Project” and click “Next”.

2. Enter the project name, e.g., org.osate.xtext.aadl2.sampleannex.analysis, and click
“Next” and “Next” again.

3. Select the “Hello, World” wizard, and click “Next” and “Finish”.

5.2 Create an action set

1. Open (double-click) on the file META-INF/MANIFEST.MF of the project
org.osate.xtext.aadl2.sampleannex.analysis

2. Open the “plugin.xm!” tab and replace its contents with the code shown in Figure 5 on page
18.

3. Save all (“File>Save All” or Shift+Ctrl+S)

5.3 Setup the dependencies
1. Open (double-click) on the file META-INF/MANIFEST.MF of the project

org.osate.xtext.aadl2.sampleannex.analysis

2. Open the “Dependencies” tab.

Click on “Add...” and enter “org.osate.aadl2.modelsupport”
Click on “Add...” and enter “org.osate.aad|2”

Click on “Add...” and enter “org.osate.ui”

Click on “Add...” and enter “org.osate.xtext.aadl2.sampleannex”

N ook @

Save all (“File>Save All” or Shift+Ctrl+S)
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<plugin>
<extension
point="org.eclipse.ui.actionSets">
<actionSet

label="0OSATE Sample Analysis Action Set"
visible="true"
id="org.osate.xtext.aadl2.sampleannex.analysis.actionSet">

<menu

© 0 N e U R W N R

[
o

id="menu.osate"
label="0OSATE"
path="project">
<groupMarker name="file.grp"/>
<separator name="instance.grp"/>
<separator name="general.grp"/>
</menu>
<menu

e e e e
L B e S N A

id="menu.analyses"
label="Analyses"
path="menu.osate">
<groupMarker
name="top.grp">
</groupMarker>
<groupMarker
name="bottom.grp">
</groupMarker>
</menu>
<menu

I N R N O I I
© ® N O s W N R O ©

id="menu.sampleanalysis"
label="Sample Analyses"
path="menu.analyses/top.grp">
<groupMarker
name="stuff.grp">
</groupMarker>
</menu>
<action
label="&amp; SampleAnalysis"
icon="icons/sample.gif"
class="org.osate.xtext.aadl2.sampleannex.analysis.actions.SampleAction"
tooltip="Sample Analysis"
menubarPath="menu.analyses/menu.contracts/stuff.grp"
toolbarPath="fault.toolbar"
id="org.osate.xtext.aadl2.sampleannex.analysis.actions.SampleAction">
</action>
</actionSet>
a7 </extension>
48 </plugin>

WA R R R R W W W W W W W W W W
S Uk W= O © WO oA W N = O

Figure 5: plugin.xml for the actionSet of org.osate.xtext.aadl2.sampleannex.analysis
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1 package org.osate.xtext.aadl2.sampleannex.analysis.actions;

import org.eclipse.core.runtime.IProgressMonitor;

import org.osate.aadl2.Element;

import org.osate.aadl2.instance.InstanceObject;

import org.osate.aadl2.modelsupport.util.AadlUtil;

import org.osate.ui.actions.AaxlReadOnlyActionAsJob;

import org.osate.ui.dialogs.Dialog;

import org.osate.xtext.aadl2.sampleannex.analysis
.visitors.SampleLangSampleAnalysisSwitch;

© 0 N ® U A W N

[

o public class SampleAction extends AaxlReadOnlyActionAsJob {

11 @Override

12 protected String getActionName () {

13 return "SampleAction";

14 }

15 @Override

16 protected void doAaxlAction(IProgressMonitor monitor, Element root) {
17

18 if (root instanceof InstanceObject) {

19 Dialog.showError ("Sample Analysis", "This analysis is done on "
20 + "declarative models only, not on instance models.

21 + "select the appropriate model (.aadl file) in the AADL
22 + "Navigator view.");

23 } else {

24 monitor.beginTask (getActionName (), IProgressMonitor.UNKNOWN) ;
25

26 SamplelLangSampleAnalysisSwitch myt =

27 new SamplelLangSampleAnalysisSwitch(monitor);

28 myt .processPreOrderAll (root);

29 monitor.done();

30 }

31 }

32 }

Figure 6: Sample action.
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5.4

Implement an action

The code for the action is implemented in a subclass of “Aax1ReadOnlyActionAsJob”. Go to

src/org.osate.xtext.aadl2.sampleannex.analysis.actions/SampleAction. java

and replace the code with the one shown in Figure 6 on page 19. This class delegates the actual
processing to an ECORE AADL switch, described in the next subsection.

5.5

Implement a switch

The actual processing of declarative (syntactic) or instance (semantic) models is done by an
EcORE “switch”. See the EMF/ECORE documentation on switches.

In the case of declarative models, such a switch contains a “caseX” method for each type of
syntactic construct X in your language (each return ECORE class in your XTEXT grammar).
If there is no case method for a given construct, then the switch will return the result of the
“defaultCase” method. Each“caseX” method receives as input an instance of the node in
the model’s AST, and its features can ge accessed with “get X” methods. The return type
must be String (a design decision of the OSATE2 developers).

In the case of instance models, the switch contains a “caseX” method for each type of semantic
object (e.g. component instance).

The code in Figure 7 on page 21 shows a typical switch to traverse a declarative model and
perform actions on the annex elements.

If you created the switch by subclassing “AadlProcessingSwitchWithProgress”, you will
have access inside the “caseX” to a monitor object that can be used to report to the user
the progress in the action with the methods “subtask” and “worked”, and which should be
polled by calling method “isCanceled” to check if the user has clicked the “Cancel” button.

In the case of AnnexLibrary and AnnexSubclause nodes, the OSATE2 parser will produce
a node of type “DefaultAnnexLibrary”’ and “DefaultAnnexSubclause” which do not repre-
sent the root of your particular annex, but have a method “getParsedAnnexLibrary”’ and
“getParsedAnnexSubclause” respectively that return the actual root of your annex. To avoid
executing twice an action on an annex library or subclause, the tests shown in lines 22-26 and
35-39 are necessary, to ensure that you are on the right node of the AST.

In the “caseX” methods for AnnexLibrary and AnnexSubclause nodes you can access the
features of the root element in your grammar (SampleLangGrammarRoot in Figure 1 on page
11), and from it you can access the AST nodes of sub-terms in your language.

A preferred and clean approach to process your particular language is to create a switch for
your language which should be an instance of the class SampleLangSwitch<T> automatically
generated by XTEXT for you and defined in the package

org.osate.xtext.aadl2.sampleannex.SamplelLang.util

found in the folder
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1 package org.osate.xtext.aadl2.sampleannex.analysis.visitors;

© 0 N e U s W N

[
o

1
12

.

13
14
15

16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46

a7

import
import
import
import
import
import
import
import
import

public

org.
org.

org

org.
org.
org.
org.
org.
org.

eclipse.core.runtime.IProgressMonitor;

osate.
.0sate.
osate.
osate.
osate.
osate.
osate.
osate.

aadl2
aadl2

aadl2
aadl2

.AnnexLibrary;
.AnnexSubclause;
aadl2.
.DefaultAnnexSubclause;
.modelsupport.modeltraversal.AadlProcessingSwitchWithProgress;
aadl2.
Xtext.
Xtext.

DefaultAnnexLibrary;

util.Aadl2Switch;
aadl2.sampleannex.Samplelang.SampleLangAnnexLibrary;
aadl2.sampleannex.Samplelang.SampleLangAnnexSubclause;

class SamplelLangSampleAnalysisSwitch extends
AadlProcessingSwitchWithProgress {

public SamplelLangSampleAnalysisSwitch (IProgressMonitor pm) {
super (pm) ;

}

@Override
protected void initSwitches() {
aadl2Switch = new Aadl2Switch<String>() {

}

};

public String caseAnnexSubclause (AnnexSubclause ob3j) {
monitor.subTask ("AnnexSubclause " + obj.getName());
if (monitor.isCanceled()) return null;

if (obj instanceof DefaultAnnexSubclause)

}

return "";
if (! (obj instanceof SamplelLangAnnexSubclause))
return "";

if (obj.getName () .equals("SampleLang")) {

}

monitor.worked (1) ;
return obj.toString();

public String caseAnnexLibrary (AnnexLibrary obj) {
monitor.subTask ("AnnexLibrary" + obj.getName());
if (monitor.isCanceled()) return null;

if (obj instanceof DefaultAnnexLibrary)

return "";
if (! (obj instanceof SamplelangAnnexLibrary))
return "";

if (obj.getName () .equals("SampleLang")) {

}

monitor.worked (1) ;
return obj.toString();

Figure 7: An ECORE switch for AADL.
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src-gen/org.osate.xtext.aadl2.sampleannex.SampleLang.util
inside the project
org.osate.xtext.aadl2.sampleannex

For example, you can define a switch like the one shown in Figure 8 on page 23. such switch
works on AST nodes specific to your language, rather than the full AADL. Note that in such
switch, you have only “caseX” specific to your grammar. and that you can use the standard
ECORE operations on AST nodes. In particular, you can obtain the features or subterms
of an AST node “obj” by invoking the method “obj.getY” for a feature or sub-term Y,
as shown in lines 9 and 15. In this example, we explicitly call the doSwitch method on
subterms, in order to control exactly which nodes will be visited. A common alternative is
to invoke a method such as “someSwitch.processPreOrderAll(root)” applied to a switch
and passing as argument the root of the AST. The “processPreOrderAll” method is defined
in the “AadlProcessingSwitch” class, together with many other traversal methods. Note,
however that such methods are defined for classes derived from “AadlProcessingSwitch”,
and not for those switches generated by XTEXT such as SampleLangSwitch<T>. If you want
more traversal methods for your specific sub-language, you have to write them yourself.

Assuming you defined this class from Figure 8 on page 23 in package
org.osate.xtext.aadl2.sampleannex.analysis.visitors

then the updated main switch would look like Figure 9 on page 24. Note that it declares
a field for the new sub-switch (line 14), creates an instance of SampleLangSpecificSwitch
in the “initSwitches” method (line 20), and then the new sub-switch is invoked with the
“doSwitch” method, passing the AST node as argument (lines 31,45).

If you wish to do analysis on an instance model instead, in the “initSwitches” method you
must initialize the “instanceSwitch” field with an instance of class “InstanceSwitch”, and in
the action of Figure 6 on page 19, you should make the creation and invocation to the switch
in the first branch of the conditional that tests if the root is an instance of InstanceObject.
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package org.osate.xtext.aadl2.sampleannex.analysis.visitors;

import org.osate.xtext.aadl2.sampleannex.SamplelLang.Stuff;

import org.osate.xtext.aadl2.sampleannex.SampleLang.Thing;

import org.osate.xtext.aadl2.sampleannex.SamplelLang.SampleLangAnnexLibrary;
import org.osate.xtext.aadl2.sampleannex.SamplelLang.SampleLangAnnexSubclause;
import org.osate.xtext.aadl2.sampleannex.SamplelLang.util.SampleLangSwitch;

@ o s W N

7 public class SamplelLangSpecificSwitch extends SamplelangSwitch<String> {

8 public String caseSamplelangAnnexLibrary (SamplelLangAnnexLibrary obj) {
9 for (Thing t : obj.getThings()) {

10 doSwitch(t);

11 }

12 return "";

13 }

14 public String caseSamplelLangAnnexSubclause (SampleLangAnnexSubclause obj) {
15 for (Stuff s : obj.getGoods()) {

16 doSwitch (s);

17 }

18 return "";

19 }

20 public String caseThing(Thing obj) {

21 System.out.println("found a thing: " + obj.getName());
22 return "";

23 }

24 public String caseStuff (Stuff obj) {

25 System.out .println("found stuff: " + obj.getName());
26 return "";

27 }

28 }

Figure 8: A (sub)language-specific switch.
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package org.osate.xtext.aadl2.sampleannex.analysis.visitors;

import
import
import
import
import
import
import
import
import
import

public

org.
org.
org.
org.

org

org.
org.
org.
org.

org

eclip

osate.
osate.
osate.
.0sate.
osate.
osate.

osate

osate.
.0sate.

se.core.runtime.IProgressMonitor;

aadl2.AnnexLibrary;

aadl2.AnnexSubclause;

aadl2.DefaultAnnexLibrary;

aadl2.DefaultAnnexSubclause;
aadl2.modelsupport.modeltraversal.AadlProcessingSwitchWithProgress;
aadl2.util.Aadl2Switch;
.xtext.aadl2.sampleannex.SamplelLang.SampleLangAnnexLibrary;
xtext.aadl2.sampleannex.SamplelLang.SampleLangAnnexSubclause;
xtext.aadl2.sampleannex.SamplelLang.util.SampleLangSwitch;

class SamplelangSampleAnalysisSwitch extends
AadlProcessingSwitchWithProgress {

protected SamplelLangSwitch<String> samplangSwitch;

public SamplelangSampleAnalysisSwitch (IProgressMonitor pm) {
super (pm) ;

}

@Override
protected void initSwitches() {

samplangSwitch = new SamplelangSpecificSwitch();
aadl2Switch = new Aadl2Switch<String>() {

};

publ

}
publ

ic String caseAnnexSubclause (AnnexSubclause obj) {
monitor.subTask ("AnnexSubclause " + obj.getName());
if (monitor.isCanceled()) return null;

if (obj instanceof DefaultAnnexSubclause)

return "";
if (! (obj instanceof SamplelLangAnnexSubclause))
return "";

if (obj.getName () .equals("SampleLang")) {

return samplangSwitch.doSwitch (ob7j);
}
monitor.worked (1) ;
return obj.toString();

ic String caseAnnexLibrary (AnnexLibrary obj) {
monitor.subTask ("AnnexLibrary" + obj.getName());
if (monitor.isCanceled()) return null;

if (obj instanceof DefaultAnnexLibrary)

return "";
if (! (obj instanceof SamplelangAnnexLibrary))
return "";

if (obj.getName () .equals("SampleLang")) {

return samplangSwitch.doSwitch (ob3j);
}
monitor.worked (1) ;
return obj.toString();

Figure 9: An ECORE switch for AADLwith a sub-switch for the sub-language.
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Description

‘ Link

Main wiki page

https://wiki.sei.cmu.edu/aadl/index.php/Osate_2

extensions. It gives
information on how to link
the parser for your language
with OSATE2.

Getting Osate 2 sources https:
//wiki.sei.cmu.edu/aadl/index.php/Getting_Osate_2_sources

Links to several pages on https:

developing OSATE2 plug-ins. | //wiki.sei.cmu.edu/aadl/index.php/0SATE_Tool_Developer

Information on sub-language | https:

//wiki.sei.cmu.edu/aadl/index.php/Sublanguage_extensions

Outdated tutorial for
sublanguage extensions This
uses ANTLR directly instead
of XTEXT, and

EcoRE directly for the
meta-model.

https:
//wiki.sei.cmu.edu/aadl/index.php/Sublanguage_Example

Information about types of
OsSATE2 plug-ins

https://wiki.sei.cmu.edu/aadl/index.php/0SATE_2_Plug-ins

Some limited information
about the OSATE2 API to
work with models.

https://wiki.sei.cmu.edu/aadl/index.php/0SATE_V2_Plugin_
Development

Implementing the action
class.

https://wiki.sei.cmu.edu/aadl/index.php/Replacing_
Aax1ReadOnlyAction_with_AaxlReadOnlyActionAsJob_in_0SATE_
1.2.4

0Old OSATE2 development,
guide.

http://www.aadl.info/aadl/currentsite/downloads/Plug-inj
20Guide’,202005-06-16%201030.pdf

6 Other references

Table 1: OSATE2 wiki links.

The OSATE2 wiki (https://wiki.sei.cmu.edu/aadl/index.php/Osate_2) contains many refer-
ences on how to develop plug-ins, but unfortunately a great deal of information is outdated, not
directly applicable to an XTEXT annex or scattered and difficult to find. That’s why I have written
these notes. Some useful links from the wiki are summarized in Table 1 on page 25.
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